summaryrefslogtreecommitdiff
path: root/plugingui/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugingui/tests/Makefile.am')
-rw-r--r--plugingui/tests/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/plugingui/tests/Makefile.am b/plugingui/tests/Makefile.am
index acc5d96..8af96ee 100644
--- a/plugingui/tests/Makefile.am
+++ b/plugingui/tests/Makefile.am
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = resizetest tabwidgettest
+noinst_PROGRAMS = resizetest tabwidgettest dgwindowtest
resizetest_LDADD = $(top_srcdir)/plugingui/libdggui.la
resizetest_CXXFLAGS = \
@@ -17,3 +17,14 @@ tabwidgettest_CXXFLAGS = \
tabwidgettest_SOURCES = \
tabwidgettest.cc \
$(top_srcdir)/hugin/hugin.c
+
+dgwindowtest_LDADD = \
+ $(top_srcdir)/plugingui/libdggui.la \
+ $(top_srcdir)/src/libdg.la
+dgwindowtest_CXXFLAGS = \
+ -I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin
+dgwindowtest_SOURCES = \
+ dgwindowtest.cc \
+ $(top_srcdir)/hugin/hugin.c