summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am153
1 files changed, 101 insertions, 52 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index c2c151d..add962a 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -25,26 +25,31 @@ TESTS += lv2
endif
check_PROGRAMS = $(TESTS)
-resource_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"resource\" $(SNDFILE_CFLAGS) \
+resource_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"resource\" \
+ $(SNDFILE_CFLAGS) \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src \
- -I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/ \
-I$(top_srcdir)/hugin
resource_LDFLAGS = $(SNDFILE_LIBS)
nodist_resource_SOURCES = \
$(top_builddir)/plugingui/resource_data.cc
resource_SOURCES = \
- $(top_srcdir)/plugingui/resource.cc \
+ $(top_srcdir)/dggui/resource.cc \
$(top_srcdir)/hugin/hugin.c \
$(top_srcdir)/src/random.cc \
uunit/uunit.cc \
drumkit_creator.cc \
resource_test.cc
-audiocache_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"audiocache\" \
+audiocache_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"audiocache\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src \
- -I$(top_srcdir)/hugin -DDISABLE_HUGIN $(PTHREAD_CFLAGS) $(SNDFILE_CFLAGS)
+ -I$(top_srcdir)/hugin -DDISABLE_HUGIN \
+ $(PTHREAD_CFLAGS) \
+ $(SNDFILE_CFLAGS)
audiocache_LDFLAGS = $(PTHREAD_LIBS) $(SNDFILE_LIBS)
audiocache_SOURCES = \
$(top_srcdir)/src/audiocache.cc \
@@ -59,10 +64,13 @@ audiocache_SOURCES = \
drumkit_creator.cc \
audiocachetest.cc
-audiocachefile_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"audiocachefile\" \
+audiocachefile_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"audiocachefile\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src \
- -I$(top_srcdir)/hugin -DDISABLE_HUGIN $(PTHREAD_CFLAGS) $(SNDFILE_CFLAGS)
+ -I$(top_srcdir)/hugin -DDISABLE_HUGIN \
+ $(PTHREAD_CFLAGS) \
+ $(SNDFILE_CFLAGS)
audiocachefile_LDFLAGS = $(PTHREAD_LIBS) $(SNDFILE_LIBS)
audiocachefile_SOURCES = \
$(top_srcdir)/src/audiocachefile.cc \
@@ -74,20 +82,25 @@ audiocachefile_SOURCES = \
drumkit_creator.cc \
audiocachefiletest.cc
-audiocacheidmanager_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"audiocacheidmanager\" \
+audiocacheidmanager_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"audiocacheidmanager\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src \
- -I$(top_srcdir)/hugin -DDISABLE_HUGIN $(SNDFILE_CFLAGS)
+ -I$(top_srcdir)/hugin -DDISABLE_HUGIN \
+ $(SNDFILE_CFLAGS)
audiocacheidmanager_LDFLAGS = $(SNDFILE_LIBS)
audiocacheidmanager_SOURCES = \
$(top_srcdir)/src/audiocacheidmanager.cc \
uunit/uunit.cc \
audiocacheidmanagertest.cc
-audiocacheeventhandler_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"audiocacheeventhandler\" \
+audiocacheeventhandler_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"audiocacheeventhandler\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src \
- -I$(top_srcdir)/hugin -DDISABLE_HUGIN $(PTHREAD_CFLAGS) $(SNDFILE_CFLAGS)
+ -I$(top_srcdir)/hugin -DDISABLE_HUGIN \
+ $(PTHREAD_CFLAGS) \
+ $(SNDFILE_CFLAGS)
audiocacheeventhandler_LDFLAGS = $(PTHREAD_LIBS) $(SNDFILE_LIBS)
audiocacheeventhandler_SOURCES = \
$(top_srcdir)/src/audiocacheeventhandler.cc \
@@ -98,10 +111,12 @@ audiocacheeventhandler_SOURCES = \
uunit/uunit.cc \
audiocacheeventhandlertest.cc
-enginetest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"enginetest\" \
+enginetest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"enginetest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src \
- -I$(top_srcdir)/hugin $(PTHREAD_CFLAGS) $(SNDFILE_CFLAGS)
+ -I$(top_srcdir)/hugin $(PTHREAD_CFLAGS) \
+ $(SNDFILE_CFLAGS)
enginetest_LDFLAGS = $(PTHREAD_LIBS) $(SNDFILE_LIBS) \
$(top_builddir)/src/libdg.la
enginetest_SOURCES = \
@@ -110,20 +125,26 @@ enginetest_SOURCES = \
drumkit_creator.cc \
enginetest.cc
-paintertest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"paintertest\" \
+paintertest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"paintertest\" \
$(DEBUG_FLAGS) \
- -I$(top_srcdir)/src -I$(top_srcdir)/plugingui \
- -I$(top_srcdir)/hugin $(PTHREAD_CFLAGS)
-paintertest_LDFLAGS = $(top_builddir)/plugingui/libdggui.la
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/ \
+ -I$(top_srcdir)/hugin \
+ $(PTHREAD_CFLAGS)
+paintertest_LDFLAGS = \
+ $(top_builddir)/dggui/libdggui.la
paintertest_SOURCES = \
$(top_srcdir)/hugin/hugin.c \
uunit/uunit.cc \
- paintertest.cc
+ paintertest.cc \
+ $(top_builddir)/plugingui/resource_data.cc
-lv2_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"lv2\" \
+lv2_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"lv2\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src \
- `pkg-config --cflags serd-0` `pkg-config --cflags lilv-0` \
+ `pkg-config --cflags serd-0` `pkg-config --cflags lilv-0` \
-DLV2_PATH=\"@LV2DIR@\" $(SNDFILE_CFLAGS)
lv2_LDFLAGS = `pkg-config --libs serd-0` \
`pkg-config --libs lilv-0` -lcrypto \
@@ -135,9 +156,11 @@ lv2_SOURCES = \
lv2_test_host.cc \
lv2.cc
-configfile_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"configfile\" \
+configfile_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"configfile\" \
$(DEBUG_FLAGS) \
- -I$(top_srcdir)/hugin -I$(top_srcdir)/src
+ -I$(top_srcdir)/hugin \
+ -I$(top_srcdir)/src
configfile_LDFLAGS =
configfile_SOURCES = \
$(top_srcdir)/src/configfile.cc \
@@ -146,7 +169,8 @@ configfile_SOURCES = \
uunit/uunit.cc \
configtest.cc
-randomtest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"randomtest\" \
+randomtest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"randomtest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src \
-I$(top_srcdir)/hugin -DDISABLE_HUGIN
@@ -157,30 +181,42 @@ randomtest_SOURCES = \
uunit/uunit.cc \
randomtest.cc
-atomictest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"atomictest\" \
+atomictest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"atomictest\" \
$(DEBUG_FLAGS) \
- -I$(top_srcdir)/src -I$(top_srcdir)/hugin
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin
atomictest_LDFLAGS =
atomictest_SOURCES = atomictest.cc uunit/uunit.cc
-syncedsettingstest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"syncedsettingstest\" \
+syncedsettingstest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"syncedsettingstest\" \
$(DEBUG_FLAGS) \
- -I$(top_srcdir)/src -I$(top_srcdir)/hugin
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin
syncedsettingstest_LDFLAGS =
syncedsettingstest_SOURCES = syncedsettings.cc uunit/uunit.cc
-imagecachetest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"imagecachetest\" \
+imagecachetest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"imagecachetest\" \
$(DEBUG_FLAGS) \
- -I$(top_srcdir)/src -I$(top_srcdir)/plugingui -I$(top_srcdir)/hugin
-imagecachetest_LDFLAGS = $(top_builddir)/plugingui/libdggui.la
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/ \
+ -I$(top_srcdir)/hugin
+imagecachetest_LDFLAGS = \
+ $(top_builddir)/dggui/libdggui.la \
+ $(top_builddir)/plugingui/libplugingui.la
imagecachetest_SOURCES = \
$(top_srcdir)/hugin/hugin.c \
imagecachetest.cc \
uunit/uunit.cc
-semaphoretest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"semaphoretest\" \
+semaphoretest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"semaphoretest\" \
$(DEBUG_FLAGS) \
- -I$(top_srcdir)/src -I$(top_srcdir)/hugin $(PTHREAD_CFLAGS)
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin \
+ $(PTHREAD_CFLAGS)
semaphoretest_LDFLAGS = $(PTHREAD_LIBS)
semaphoretest_SOURCES = \
$(top_srcdir)/hugin/hugin.c \
@@ -188,10 +224,12 @@ semaphoretest_SOURCES = \
semaphoretest.cc \
uunit/uunit.cc
-drumkitcreatortest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"drumkitcreatortest\" \
+drumkitcreatortest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"drumkitcreatortest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src \
- -I$(top_srcdir)/hugin -DDISABLE_HUGIN $(SNDFILE_CFLAGS)
+ -I$(top_srcdir)/hugin -DDISABLE_HUGIN \
+ $(SNDFILE_CFLAGS)
drumkitcreatortest_CFLAGS = -DDISABLE_HUGIN
drumkitcreatortest_LDFLAGS = $(SNDFILE_LIBS)
drumkitcreatortest_SOURCES = \
@@ -200,7 +238,8 @@ drumkitcreatortest_SOURCES = \
drumkit_creator.cc \
drumkitcreatortest.cc
-bytesizeparsertest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"bytesizeparsertest\" \
+bytesizeparsertest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"bytesizeparsertest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src
bytesizeparsertest_LDFLAGS =
@@ -209,7 +248,8 @@ bytesizeparsertest_SOURCES = \
bytesizeparsertest.cc \
uunit/uunit.cc
-notifiertest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"notifiertest\" \
+notifiertest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"notifiertest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src
notifiertest_LDFLAGS =
@@ -217,9 +257,11 @@ notifiertest_SOURCES = \
notifiertest.cc \
uunit/uunit.cc
-dgxmlparsertest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"dgxmlparsertest\" \
+dgxmlparsertest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"dgxmlparsertest\" \
$(DEBUG_FLAGS) \
- -I$(top_srcdir)/src -I$(top_srcdir)/hugin \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin \
-I$(top_srcdir)/pugixml/src
dgxmlparsertest_LDFLAGS =
dgxmlparsertest_SOURCES = \
@@ -230,7 +272,8 @@ dgxmlparsertest_SOURCES = \
scopedfile.cc \
uunit/uunit.cc
-domloadertest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"domloadertest\" \
+domloadertest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"domloadertest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src
domloadertest_LDFLAGS = \
@@ -241,9 +284,11 @@ domloadertest_SOURCES = \
scopedfile.cc \
uunit/uunit.cc
-configparsertest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"configparsertest\" \
+configparsertest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"configparsertest\" \
$(DEBUG_FLAGS) \
- -I$(top_srcdir)/src -I$(top_srcdir)/hugin \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin \
-I$(top_srcdir)/pugixml/src
configparsertest_LDFLAGS =
configparsertest_SOURCES = \
@@ -253,9 +298,11 @@ configparsertest_SOURCES = \
configparsertest.cc \
uunit/uunit.cc
-midimapparsertest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"midimapparsertest\" \
+midimapparsertest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"midimapparsertest\" \
$(DEBUG_FLAGS) \
- -I$(top_srcdir)/src -I$(top_srcdir)/hugin \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin \
-I$(top_srcdir)/pugixml/src
midimapparsertest_LDFLAGS =
midimapparsertest_SOURCES = \
@@ -266,7 +313,8 @@ midimapparsertest_SOURCES = \
midimapparsertest.cc \
uunit/uunit.cc
-eventsdstest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"eventsdstest\" \
+eventsdstest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"eventsdstest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src
eventsdstest_LDFLAGS =
@@ -275,7 +323,8 @@ eventsdstest_SOURCES = \
eventsdstest.cc \
uunit/uunit.cc
-powermaptest_CXXFLAGS = -I$(top_srcdir)/test/uunit -DOUTPUT=\"powermaptest\" \
+powermaptest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"powermaptest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src
powermaptest_LDFLAGS =
@@ -291,12 +340,12 @@ rcgen_verbose = $(rcgen_verbose_@AM_V@)
rcgen_verbose_ = $(rcgen_verbose_@AM_DEFAULT_V@)
rcgen_verbose_0 = @echo " RCGEN "$@;
-translationtest_resource_data.cc: $(top_builddir)/plugingui/rcgen $(RES)
- $(rcgen_verbose)$(top_builddir)/plugingui/rcgen$(EXEEXT) -s $(top_srcdir)/test/ -o $@ $(RES)
+translationtest_resource_data.cc: $(top_builddir)/dggui/rcgen $(RES)
+ $(rcgen_verbose)$(top_builddir)/dggui/rcgen$(EXEEXT) -s $(top_srcdir)/test/ -o $@ $(RES)
-translationtest_CXXFLAGS = -I$(top_srcdir)/test/uunit \
- -DOUTPUT=\"translationtest\" \
- -I$(top_srcdir)/plugingui \
+translationtest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"translationtest\" \
+ -I$(top_srcdir)/ \
-I$(top_srcdir)/src \
-I$(top_srcdir)/hugin \
-DMO_SRC=\"$(top_srcdir)/test/locale/da.mo\" \
@@ -306,9 +355,9 @@ nodist_translationtest_SOURCES = \
$(top_builddir)/test/translationtest_resource_data.cc
translationtest_SOURCES = \
$(top_srcdir)/hugin/hugin.c \
- $(top_srcdir)/plugingui/resource.cc \
+ $(top_srcdir)/dggui/resource.cc \
$(top_srcdir)/src/translation.cc \
- $(top_srcdir)/plugingui/uitranslation.cc \
+ $(top_srcdir)/dggui/uitranslation.cc \
translationtest.cc \
uunit/uunit.cc