summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 15ceb7d..64b2462 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -8,7 +8,7 @@ TESTS = resource enginetest paintertest configfile audiocache \
randomtest atomictest syncedsettingstest imagecachetest \
semaphoretest drumkitcreatortest bytesizeparsertest notifiertest \
dgxmlparsertest domloadertest configparsertest midimapparsertest \
- eventsdstest powermaptest midimappertest
+ eventsdstest powermaptest midimappertest positionpowertest
if WITH_NLS
TESTS += translationtest
@@ -354,6 +354,17 @@ midimappertest_SOURCES = \
midimappertest.cc \
uunit/uunit.cc
+positionpowertest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"positionpowertest\" \
+ $(DEBUG_FLAGS) \
+ -I$(top_srcdir)/src
+positionpowertest_LDFLAGS =
+positionpowertest_SOURCES = \
+ $(top_srcdir)/src/sample.cc \
+ $(top_srcdir)/src/position_power.cc \
+ position_power_test.cc \
+ uunit/uunit.cc
+
RES = \
$(top_srcdir)/test/locale/da.mo