summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6d62314..6441fd3 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -8,7 +8,7 @@ TESTS = resource enginetest paintertest configfile audiocache \
randomtest atomictest syncedsettingstest imagecachetest \
semaphoretest drumkitcreatortest bytesizeparsertest notifiertest \
dgxmlparsertest domloadertest configparsertest midimapparsertest \
- eventsdstest powermaptest
+ eventsdstest powermaptest midimappertest
if WITH_NLS
TESTS += translationtest
@@ -335,6 +335,21 @@ powermaptest_SOURCES = \
powermaptest.cc \
uunit/uunit.cc
+midimappertest_CXXFLAGS = \
+ -I$(top_srcdir)/test/uunit -DOUTPUT=\"midimappertest\" \
+ $(DEBUG_FLAGS) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin \
+ -I$(top_srcdir)/pugixml/src
+midimappertest_LDFLAGS =
+midimappertest_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ $(top_srcdir)/src/midimapper.cc \
+ $(top_srcdir)/pugixml/src/pugixml.cpp \
+ scopedfile.cc \
+ midimappertest.cc \
+ uunit/uunit.cc
+
RES = \
$(top_srcdir)/test/locale/da.mo