summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6e56043..ccb21e6 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -3,7 +3,7 @@ include $(top_srcdir)/src/Makefile.am.drumgizmo
TESTS = resource engine gui resampler lv2 configfile audiocache \
audiocachefile audiocacheidmanager audiocacheeventhandler \
- memchecker
+ memchecker random
check_PROGRAMS = $(TESTS)
@@ -128,5 +128,15 @@ memchecker_SOURCES = \
test.cc \
memcheckertest.cc
+random_CXXFLAGS = -DOUTPUT=\"random\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin -DDISABLE_HUGIN
+random_CFLAGS = -DDISABLE_HUGIN
+random_LDFLAGS = $(CPPUNIT_LIBS)
+random_SOURCES = \
+ $(top_srcdir)/src/random.cc \
+ test.cc \
+ randomtest.cc
+
EXTRA_DIST = \
lv2_test_host.h