summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index defd63d..29ab4b1 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,10 +1,20 @@
# Rules for the test code (use `make check` to execute)
include $(top_srcdir)/src/Makefile.am.drumgizmo
-TESTS = engine gui resampler lv2 configfile
+TESTS = resource engine gui resampler lv2 configfile
check_PROGRAMS = $(TESTS)
+resource_CXXFLAGS = -DOUTPUT=\"resource\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/hugin
+resource_LDFLAGS = $(CPPUNIT_LIBS)
+resource_SOURCES = \
+ $(top_srcdir)/plugingui/resource.cc \
+ $(top_srcdir)/plugingui/resource_data.cc \
+ $(top_srcdir)/hugin/hugin.c \
+ test.cc \
+ resource_test.cc
+
engine_CXXFLAGS = -DOUTPUT=\"engine\" $(CPPUNIT_CFLAGS) \
-I$(top_srcdir)/src -I$(top_srcdir)/include \
-I$(top_srcdir)/hugin -DDISABLE_HUGIN
@@ -51,4 +61,4 @@ configfile_SOURCES = \
configtest.cc
EXTRA_DIST = \
- lv2_test_host.h \ No newline at end of file
+ lv2_test_host.h