summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 1b4470d..e8d9a75 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -5,7 +5,8 @@ include $(top_srcdir)/src/Makefile.am.drumgizmo
TESTS = resource engine gui resampler lv2 configfile audiocache \
audiocachefile audiocacheidmanager audiocacheeventhandler \
- memchecker randomtest atomictest syncedsettingstest imagecachetest
+ memchecker randomtest atomictest syncedsettingstest imagecachetest \
+ semaphoretest
check_PROGRAMS = $(TESTS)
@@ -164,3 +165,12 @@ imagecachetest_SOURCES = \
$(top_srcdir)/plugingui/colour.cc \
imagecachetest.cc \
test.cc
+
+semaphoretest_CXXFLAGS = -DOUTPUT=\"semaphoretest\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/hugin
+semaphoretest_LDFLAGS = $(CPPUNIT_LIBS)
+semaphoretest_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ $(top_srcdir)/src/semaphore.cc \
+ semaphoretest.cc \
+ test.cc