summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 26ffa81..bf21a0b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -7,7 +7,7 @@ TESTS = resource enginetest paintertest resampler configfile audiocache \
audiocachefile audiocacheidmanager audiocacheeventhandler \
randomtest atomictest syncedsettingstest imagecachetest \
semaphoretest drumkitcreatortest bytesizeparsertest notifiertest \
- instrumentparsertest
+ instrumentparsertest drumkitparsertest
if ENABLE_LV2
TESTS += lv2
@@ -223,4 +223,14 @@ instrumentparsertest_SOURCES = \
scopedfile.cc \
test.cc
+drumkitparsertest_CXXFLAGS = -DOUTPUT=\"drumkitparsertest\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/include
+drumkitparsertest_LDFLAGS = $(CPPUNIT_LIBS) \
+ $(top_srcdir)/src/libdg.la
+drumkitparsertest_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ drumkitparsertest.cc \
+ scopedfile.cc \
+ test.cc
+
endif