summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4a5a050..c45ed60 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -7,7 +7,7 @@ TESTS = resource enginetest paintertest configfile audiocache \
audiocachefile audiocacheidmanager audiocacheeventhandler \
randomtest atomictest syncedsettingstest imagecachetest \
semaphoretest drumkitcreatortest bytesizeparsertest notifiertest \
- instrumentparsertest drumkitparsertest
+ instrumentparsertest drumkitparsertest dgxmlparsertest
EXTRA_DIST = \
dgunit.h \
@@ -214,4 +214,15 @@ drumkitparsertest_SOURCES = \
scopedfile.cc \
dgtest.cc
+dgxmlparsertest_CXXFLAGS = -DOUTPUT=\"dgxmlparsertest\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/include -I$(top_srcdir)/pugixml/src
+dgxmlparsertest_LDFLAGS = $(CPPUNIT_LIBS)
+dgxmlparsertest_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ $(top_srcdir)/src/dgxmlparser.cc \
+ $(top_srcdir)/pugixml/src/pugixml.cpp \
+ dgxmlparsertest.cc \
+ scopedfile.cc \
+ test.cc
+
endif