summaryrefslogtreecommitdiff
path: root/test/uitests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/uitests/Makefile.am')
-rw-r--r--test/uitests/Makefile.am31
1 files changed, 19 insertions, 12 deletions
diff --git a/test/uitests/Makefile.am b/test/uitests/Makefile.am
index 8b1877e..a27a44b 100644
--- a/test/uitests/Makefile.am
+++ b/test/uitests/Makefile.am
@@ -2,11 +2,12 @@ noinst_PROGRAMS = resizetest tabwidgettest framewidgettest \
filebrowsertest benchmarktest powerwidgettest
resizetest_LDADD = \
- $(top_builddir)/plugingui/libdggui.la \
+ $(top_builddir)/dggui/libdggui.la \
+ $(top_builddir)/plugingui/libplugingui.la \
$(top_builddir)/src/libdg.la \
$(top_builddir)/src/libnls.la
resizetest_CXXFLAGS = \
- -I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/ \
-I$(top_srcdir)/src \
-I$(top_srcdir)/hugin
resizetest_SOURCES = \
@@ -14,11 +15,12 @@ resizetest_SOURCES = \
$(top_srcdir)/hugin/hugin.c
tabwidgettest_LDADD = \
- $(top_builddir)/plugingui/libdggui.la \
+ $(top_builddir)/dggui/libdggui.la \
+ $(top_builddir)/plugingui/libplugingui.la \
$(top_builddir)/src/libdg.la \
$(top_builddir)/src/libnls.la
tabwidgettest_CXXFLAGS = \
- -I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/ \
-I$(top_srcdir)/src \
-I$(top_srcdir)/hugin
tabwidgettest_SOURCES = \
@@ -26,11 +28,13 @@ tabwidgettest_SOURCES = \
$(top_srcdir)/hugin/hugin.c
filebrowsertest_LDADD = \
- $(top_builddir)/plugingui/libdggui.la \
+ $(top_builddir)/dggui/libdggui.la \
+ $(top_builddir)/plugingui/libplugingui.la \
$(top_builddir)/src/libdg.la \
$(top_builddir)/src/libnls.la
filebrowsertest_CXXFLAGS = \
-I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/ \
-I$(top_srcdir)/src \
-I$(top_srcdir)/hugin
filebrowsertest_SOURCES = \
@@ -38,11 +42,12 @@ filebrowsertest_SOURCES = \
$(top_srcdir)/hugin/hugin.c
framewidgettest_LDADD = \
- $(top_builddir)/plugingui/libdggui.la \
+ $(top_builddir)/dggui/libdggui.la \
+ $(top_builddir)/plugingui/libplugingui.la \
$(top_builddir)/src/libdg.la \
$(top_builddir)/src/libnls.la
framewidgettest_CXXFLAGS = \
- -I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/ \
-I$(top_srcdir)/src \
-I$(top_srcdir)/hugin
framewidgettest_SOURCES = \
@@ -59,15 +64,15 @@ rcgen_verbose = $(rcgen_verbose_@AM_V@)
rcgen_verbose_ = $(rcgen_verbose_@AM_DEFAULT_V@)
rcgen_verbose_0 = @echo " RCGEN "$@;
-benchmarktest_resource_data.cc: $(top_builddir)/plugingui/rcgen $(RES)
- $(rcgen_verbose)$(top_builddir)/plugingui/rcgen$(EXEEXT) -d $(top_srcdir)/test/uitests -o $@ $(RES)
+benchmarktest_resource_data.cc: $(top_builddir)/dggui/rcgen $(RES)
+ $(rcgen_verbose)$(top_builddir)/dggui/rcgen$(EXEEXT) -d $(top_srcdir)/test/uitests -o $@ $(RES)
benchmarktest_LDADD = \
- $(top_builddir)/plugingui/libdggui.la \
+ $(top_builddir)/dggui/libdggui.la \
$(top_builddir)/src/libdg.la \
$(top_builddir)/src/libnls.la
benchmarktest_CXXFLAGS = \
- -I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/ \
-I$(top_srcdir)/src \
-I$(top_srcdir)/hugin
nodist_benchmarktest_SOURCES = \
@@ -81,11 +86,13 @@ CLEANFILES = benchmarktest_resource_data.cc
powerwidgettest_LDADD = \
- $(top_builddir)/plugingui/libdggui.la \
+ $(top_builddir)/dggui/libdggui.la \
+ $(top_builddir)/plugingui/libplugingui.la \
$(top_builddir)/src/libdg.la \
$(top_builddir)/src/libnls.la
powerwidgettest_CXXFLAGS = \
-I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/ \
-I$(top_srcdir)/src \
-I$(top_srcdir)/hugin
powerwidgettest_SOURCES = \