summaryrefslogtreecommitdiff
path: root/test/uitests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/uitests/Makefile.am')
-rw-r--r--test/uitests/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/uitests/Makefile.am b/test/uitests/Makefile.am
index bd2c6d1..6a5894b 100644
--- a/test/uitests/Makefile.am
+++ b/test/uitests/Makefile.am
@@ -1,5 +1,5 @@
noinst_PROGRAMS = resizetest tabwidgettest framewidgettest \
- filebrowsertest benchmarktest
+ filebrowsertest benchmarktest powerwidgettest
resizetest_LDADD = \
$(top_builddir)/plugingui/libdggui.la \
@@ -66,4 +66,15 @@ benchmarktest_SOURCES = \
benchmarktest_resource_data.cc \
$(top_srcdir)/hugin/hugin.c
+powerwidgettest_LDADD = \
+ $(top_builddir)/plugingui/libdggui.la \
+ $(top_builddir)/src/libdg.la
+powerwidgettest_CXXFLAGS = \
+ -I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin
+powerwidgettest_SOURCES = \
+ powerwidgettest.cc \
+ $(top_srcdir)/hugin/hugin.c
+
EXTRA_DIST = $(RES)