summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2016-04-17 12:19:59 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2016-04-17 20:15:06 +0200
commit02b46fa70addd49ce1b7c0a04e56c33963f0e1c2 (patch)
tree09cf9a6dd9b27c3a4b48e339247484881bce3b72 /configure.ac
parent4eb252df04ab237c8638d45bcbf028859dc6a110 (diff)
Fix vstsdk compilation on linux (thanks falktx).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1745714..92f2a81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,6 +174,15 @@ AS_IF(
[test "x$enable_vst" = "xyes"],
[enable_vst=yes
VST_CPPFLAGS="-I$with_vst_sources -D__int64='long long int'"
+
+ # Set up platform specific workarounds for the VST SDK
+ AS_CASE([$host_os],
+ [darwin*], [ ],
+ [linux*|*bsd*], [VST_CPPFLAGS="$VST_CPPFLAGS -D__cdecl="],
+ [mingw*|windows*|winnt|cygwin], [ ],
+ AC_MSG_ERROR([Your platform is not currently supported])
+ )
+
VST_SOURCE_PATH="$with_vst_sources"
AC_SUBST(VST_SOURCE_PATH)
AC_SUBST(VST_CPPFLAGS)