summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-06-05 18:53:20 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2014-06-05 18:53:20 +0200
commit0894c93aa851826b712c51a36d2390fe030d1073 (patch)
tree1862221c8ce18180ec235808976b06f0e1c5ecd3 /configure.ac
parentb91fe74814c2217072860611d0b9c2d645db6b9b (diff)
Experimentally add VST to autotools (probably highly broken)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 13 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index c3fc352..997d140 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,23 +120,19 @@ else
fi
AM_CONDITIONAL([ENABLE_LV2], [test "x$enable_lv2" = "xyes"])
-#dnl ======================
-#dnl Compile VST plugin
-#dnl ======================
-#AC_ARG_ENABLE([vst],
-#[ --enable-vst Compile the VST plugin [default=yes]],,
-# [enable_vst="yes"])
-#if test "x$enable_vst" = "xyes"; then
-# enable_vst=yes
-# dnl ======================
-# dnl Check for vstcore
-# dnl ======================
-# PKG_CHECK_MODULES(VST, vstcore >= 4.1)
-#else
-# AC_MSG_RESULT([*** VST plugin will not be compiled ***])
-# enable_vst=no
-#fi
-#AM_CONDITIONAL([ENABLE_VST], [test "x$enable_vst" = "xyes"])
+dnl ======================
+dnl Compile VST plugin
+dnl ======================
+AC_ARG_ENABLE([vst],
+[ --enable-vst Compile the VST plugin [default=yes]],,
+ [enable_vst="yes"])
+if test "x$enable_vst" = "xyes"; then
+ enable_vst=yes
+else
+ AC_MSG_RESULT([*** VST plugin will not be compiled ***])
+ enable_vst=no
+fi
+AM_CONDITIONAL([ENABLE_VST], [test "x$enable_vst" = "xyes"])
dnl ======================
dnl Compile AU plugin