summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-03-06 19:37:45 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2014-03-06 19:37:45 +0100
commit94ae7f27812b3de5bd1046b758f5bb95eacc59be (patch)
treee206c91940ce3aa5331b661697b86bb55d696b86 /configure.ac
parent0b31e1d2ed17121a854e31b282dc1848de59ce4b (diff)
Include icons folder in distfile.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 6 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 0562059..58b4eac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,13 +36,6 @@ if test x$with_experimental == xyes; then
CXXFLAGS="$CXXFLAGS -DEXPERIMENTAL"
fi
-#AC_ARG_ENABLE(pugl, [ --enable-pugl Build with Pugl support])
-#if test x$enable_pugl == xyes; then
-# AC_MSG_WARN([*** Building with pugl support!])
-# CXXFLAGS="$CXXFLAGS -DPUGL -lGL -lGLU -lglut"
-#fi
-#AM_CONDITIONAL([ENABLE_PUGL], [test "x$enable_pugl" = "xyes"])
-
dnl ===========================
dnl Check for GUI backend
dnl ===========================
@@ -93,7 +86,7 @@ elif test "x$enable_gui" = "xwin32"; then
elif test "x$enable_gui" = "xpugl"; then
AC_MSG_RESULT([Setting gui backend to Pugl])
- GUI_CFLAGS="-DPUGL"
+ GUI_CFLAGS="-DPUGL -I../../pugl"
GUI_LIBS="-lGLU -lGL -lglut"
else
@@ -105,18 +98,9 @@ AC_SUBST(GUI_LIBS)
AM_CONDITIONAL([ENABLE_PUGL], [test "x$enable_gui" = "xpugl"])
-
-
-
-
-
-
-
-
-
-
-
-
+dnl ======================
+dnl Compile unit tests
+dnl ======================
AC_ARG_WITH(test, [ --with-test Build unit tests])
if test x$with_test == xyes; then
AC_MSG_WARN([*** Building unittests!])
@@ -527,5 +511,5 @@ AC_OUTPUT(
drumgizmo/output/alsa/Makefile
drumgizmo/output/jackaudio/Makefile
drumgizmo/output/wavfile/Makefile
- dgedit/Makefile)
-
+ dgedit/Makefile
+ dgedit/icons/Makefile)