summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-06-07 12:23:32 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2014-06-07 12:23:32 +0200
commitd76e2ed2483aff0c246a729c242c4c57b48d8996 (patch)
tree4f92255a4556898cf2ddab0b9623e46aee1c0f35 /configure.ac
parentad63d0c777b344cccc6f5f4e9dbeda2c96e1a87a (diff)
Set VST path
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 47d8b1e..ef867e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,17 +123,23 @@ AM_CONDITIONAL([ENABLE_LV2], [test "x$enable_lv2" = "xyes"])
dnl ======================
dnl Compile VST plugin
dnl ======================
+AC_ARG_WITH(vst_sources, [ --with-vst-sources Point this to the vstsdk24 directory])
AC_ARG_ENABLE([vst],
[ --enable-vst Compile the VST plugin [default=no]],,
[enable_vst="no"])
if test "x$enable_vst" = "xyes"; then
- enable_vst=yes
+ enable_vst=yes
+ VST_CPPFLAGS="-I$with_vst_sources"
+ VST_SOURCE_PATH="$with_vst_sources"
+ AC_SUBST(VST_SOURCE_PATH)
+ AC_SUBST(VST_CPPFLAGS)
else
AC_MSG_RESULT([*** VST plugin will not be compiled ***])
enable_vst=no
fi
AM_CONDITIONAL([ENABLE_VST], [test "x$enable_vst" = "xyes"])
+
dnl ======================
dnl Compile AU plugin
dnl ======================