summaryrefslogtreecommitdiff
path: root/drumgizmo/Makefile.am
diff options
context:
space:
mode:
authorVolker Fischer <corrados@users.noreply.github.com>2021-02-09 20:32:10 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2021-02-09 20:32:10 +0100
commit3dd3c332414bfbebd69bfd71a4a3198198525eb6 (patch)
tree9dff61eab647703581c80b1e1b276571586696d7 /drumgizmo/Makefile.am
parent9310ffe5959ce4de02204b6cd251d4b4a58c69b9 (diff)
Add ALSA midi input support.
Diffstat (limited to 'drumgizmo/Makefile.am')
-rw-r--r--drumgizmo/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/drumgizmo/Makefile.am b/drumgizmo/Makefile.am
index b3bca32..7702b2e 100644
--- a/drumgizmo/Makefile.am
+++ b/drumgizmo/Makefile.am
@@ -77,6 +77,10 @@ drumgizmo_SOURCES += input/ossmidi.cc
drumgizmo_CXXFLAGS += -DHAVE_INPUT_OSSMIDI
endif # HAVE_INPUT_OSSMIDI
+if HAVE_INPUT_ALSAMIDI
+drumgizmo_SOURCES += input/alsamidi.cc
+drumgizmo_CXXFLAGS += -DHAVE_INPUT_ALSAMIDI
+endif # HAVE_INPUT_ALSAMIDI
# Only compile jackclient.cc if at least one of the jack modules are included.
if HAVE_OUTPUT_JACKAUDIO
@@ -93,6 +97,7 @@ EXTRA_DIST = \
input/inputdummy.h \
input/test.h \
input/jackmidi.h \
+ input/alsamidi.h \
input/midifile.h \
input/ossmidi.h \
output/alsa.h \