summaryrefslogtreecommitdiff
path: root/drumgizmo/input/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-12-05 23:45:37 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2014-12-05 23:45:37 +0100
commit64d4f8d1b55d7f3f4099bd185ca326b5331798cc (patch)
tree0a4c980f30db06a02e26468b22b90b59043d5ab5 /drumgizmo/input/test/Makefile.am
parent07ab6e89cdc218636246191251c229ac289502b2 (diff)
Clean up cli client module names. Fix autotools paths.
Diffstat (limited to 'drumgizmo/input/test/Makefile.am')
-rw-r--r--drumgizmo/input/test/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/drumgizmo/input/test/Makefile.am b/drumgizmo/input/test/Makefile.am
index 0b65a67..35466ab 100644
--- a/drumgizmo/input/test/Makefile.am
+++ b/drumgizmo/input/test/Makefile.am
@@ -4,7 +4,7 @@ testsources = \
if HAVE_INPUT_TEST
-testltlibs = libtest.la
+testltlibs = test.la
testbuildsources = $(testsources)
else
@@ -21,6 +21,9 @@ lib_LTLIBRARIES = $(testltlibs)
libdir = $(INPUT_PLUGIN_DIR)
AM_CPPFLAGS = -I$(top_srcdir)/include
-libtest_la_LDFLAGS =
-libtest_la_LIBADD =
-libtest_la_SOURCES = $(testbuildsources)
+test_la_LDFLAGS = -module -avoid-version -shared
+test_la_LIBADD =
+test_la_SOURCES = $(testbuildsources)
+
+install-exec-hook:
+ rm -f $(DESTDIR)$(libdir)/test.la