summaryrefslogtreecommitdiff
path: root/plugin/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2019-04-17 11:37:08 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2019-04-17 19:53:39 +0200
commitf5890ca723139636cc7c64d79f46e30780f59a25 (patch)
treef9d1dc99b5afa9d8925205a45a90819a4e0ada5c /plugin/Makefile.am
parent723343269d161b2bba7aee4597357ffc32f26f04 (diff)
Added ttlgen dynamic ttl manifest generator the LV2 plugin.
Diffstat (limited to 'plugin/Makefile.am')
-rw-r--r--plugin/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/plugin/Makefile.am b/plugin/Makefile.am
index fcb307e..02dc5a3 100644
--- a/plugin/Makefile.am
+++ b/plugin/Makefile.am
@@ -1,4 +1,5 @@
SUBDIRS = vst
+noinst_PROGRAMS =
#######
@@ -7,7 +8,8 @@ SUBDIRS = vst
if ENABLE_LV2
lv2plugindir = @LV2DIR@/drumgizmo.lv2
lv2plugin_LTLIBRARIES = drumgizmo.la
-lv2plugin_DATA = manifest.ttl drumgizmo.ttl
+noinst_PROGRAMS += ttlgen
+lv2plugin_DATA = manifest.ttl
endif
drumgizmo_la_CXXFLAGS = -DLV2 -DLV2_PLUGIN_URI=\"http://drumgizmo.org/lv2\" \
@@ -34,6 +36,14 @@ drumgizmo_la_LIBADD = $(LV2_LIBS) \
$(top_srcdir)/plugingui/libdggui.la \
$(top_srcdir)/src/libdg.la
+ttlgen_CPPFLAGS = $(DL_CFLAGS) -I$(top_srcdir)/plugin/plugingizmo
+ttlgen_LDFLAGS = $(DL_LIBS)
+ttlgen_SOURCES = \
+ $(top_srcdir)/plugin/plugingizmo/ttlgen.cc
+
+manifest.ttl : ttlgen drumgizmo.la
+ ./ttlgen .libs/drumgizmo.so manifest.ttl
+
#######
# VST