summaryrefslogtreecommitdiff
path: root/plugingui/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2020-04-26 21:29:52 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2020-04-26 21:50:14 +0200
commit2cad525e2babac75395caf367449d9e9b31fcd42 (patch)
tree653e5d03f43414e3347be176f816d4f5a9015c5d /plugingui/Makefile.am
parent20c5726e9442ebaf3711043cc0f317a600fb9c75 (diff)
Fix out-of-tree building.
Diffstat (limited to 'plugingui/Makefile.am')
-rw-r--r--plugingui/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/plugingui/Makefile.am b/plugingui/Makefile.am
index 91e95bf..10bf23a 100644
--- a/plugingui/Makefile.am
+++ b/plugingui/Makefile.am
@@ -33,11 +33,12 @@ RES = \
../BUGS \
../COPYING
-resource_data.cc : rcgen $(RES)
- ./rcgen $(RES) > resource_data.cc
+resource_data.cc: rcgen $(RES)
+ ./rcgen -d $(top_srcdir)/plugingui $(RES) > $(top_srcdir)/plugingui/resource_data.cc
libdggui_la_CPPFLAGS = \
$(DEBUG_FLAGS) \
+ -I$(top_srcdir) \
$(GUI_CPPFLAGS) \
-I$(top_srcdir)/hugin \
-I$(top_srcdir)/src \
@@ -163,7 +164,7 @@ libdggui_la_CPPFLAGS += \
-I$(top_srcdir)/pugl
endif
-plugingui_LDADD = libdggui.la $(top_srcdir)/src/libdg.la
+plugingui_LDADD = libdggui.la $(top_builddir)/src/libdg.la
plugingui_CXXFLAGS = \
$(DEBUG_FLAGS) \