summaryrefslogtreecommitdiff
path: root/vst/Makefile.am
diff options
context:
space:
mode:
authorJonas Suhr Christensen <jsc@umbraculum.org>2014-12-05 23:50:25 +0100
committerJonas Suhr Christensen <jsc@umbraculum.org>2014-12-05 23:50:25 +0100
commit33f888cd8ba0bbb258b0cec6568f60801364c697 (patch)
tree0ef2ee00d843492f39e65781992552b14e611ebf /vst/Makefile.am
parentd31ef86d0b51092bab5813f1cc893fdf6d688123 (diff)
parent64d4f8d1b55d7f3f4099bd185ca326b5331798cc (diff)
Merge branch 'master' of http://git.drumgizmo.org/drumgizmov0.9.7
Forced to write this message.
Diffstat (limited to 'vst/Makefile.am')
-rw-r--r--vst/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/vst/Makefile.am b/vst/Makefile.am
index e2a920c..7bb7214 100644
--- a/vst/Makefile.am
+++ b/vst/Makefile.am
@@ -11,7 +11,7 @@ VST_SOURCES = \
AM_CPPFLAGS = -I$(top_srcdir)/hugin -DWITH_HUG_SYSLOG -DWITH_HUG_MUTEX
EXTRA_DIST = \
- Makefile.mingw32 \
+ Makefile.mingw32.in \
constants.h \
drumgizmo_vst.cc \
drumgizmo_vst.h \
@@ -20,10 +20,9 @@ EXTRA_DIST = \
output_vst.cc \
output_vst.h
-plugindir = $(prefix)/vst
-plugin_LTLIBRARIES =
-
if ENABLE_VST
+plugin_LTLIBRARIES =
+plugindir = $(prefix)/lib/vst
plugin_LTLIBRARIES += libdrumgizmo_vst.la
noinst_LTLIBRARIES = libdg.la
endif
@@ -40,8 +39,10 @@ libdg_la_CXXFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/plugingui \
$(PLUGIN_GUI_CFLAGS) $(SSEFLAGS)\
-DUSE_THREAD $(SAMPLERATE_CFLAGS)
+nodist_libdrumgizmo_vst_la_SOURCES = \
+ $(VST_SOURCES)
+
libdrumgizmo_vst_la_SOURCES = \
- $(VST_SOURCES) \
drumgizmo_vst.cc \
input_vst.cc \
output_vst.cc