summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 35 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1151ad1..28c492d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,7 @@ AC_SYS_LARGEFILE
AM_SILENT_RULES([yes])
need_jack=no
+need_alsa=no
dnl ===========================
dnl Compile with C++11 support.
@@ -71,7 +72,7 @@ dnl Check for -ffloat-store support
dnl ===========================
AC_LANG_PUSH([C++])
TMP_CXXFLAGS="$CXXFLAGS"
-CXXFLAGS="-Wall -Werror -ffloat-store"
+CXXFLAGS="-Wall -Werror -Wextra -ffloat-store"
AC_MSG_CHECKING([whether CXX supports -ffloat-store])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
[AC_MSG_RESULT([yes])
@@ -148,8 +149,14 @@ AC_ARG_WITH([nls],
AS_IF([test "x$with_nls" == "xyes"],
[AC_MSG_RESULT([*** Building with nls support!])
AC_CHECK_PROGS([XGETTEXT], [xgettext])
+ AS_IF([test "x$XGETTEXT" = "x"],
+ AC_MSG_ERROR([Missing xgettext tool.]))
AC_CHECK_PROGS([MSGMERGE], [msgmerge])
+ AS_IF([test "x$MSGMERGE" = "x"],
+ AC_MSG_ERROR([Missing msgmerge tool.]))
AC_CHECK_PROGS([MSGFMT], [msgfmt])
+ AS_IF([test "x$MSGFMT" = "x"],
+ AC_MSG_ERROR([Missing msgfmt tool.]))
AC_DEFINE_UNQUOTED([WITH_NLS], , [Build with nls support])],
[AC_MSG_WARN([*** Building without nls support!])]
)
@@ -362,6 +369,11 @@ AS_IF(
dnl ======================
AC_CHECK_HEADERS(getopt.h)
+ dnl ======================
+ dnl Check for wordexp
+ dnl ======================
+ AC_CHECK_FUNCS([wordexp])
+
dnl ***
dnl *** Input plugins
dnl ***
@@ -406,6 +418,20 @@ AS_IF(
have_input_jackmidi=no]
)
+ dnl *** alsamidi
+ AC_ARG_ENABLE([input_alsamidi],
+ AS_HELP_STRING([--disable-input-alsamidi], [Disable input alsamidi plugin [default=enabled]]),,
+ [enable_input_alsamidi="yes"])
+
+ AS_IF(
+ [test "x$enable_input_alsamidi" = "xyes"],
+ [have_input_alsamidi=yes
+ need_alsa=yes],
+
+ [AC_MSG_RESULT([*** input alsamidi plugin disabled per user request ***])
+ have_input_alsamidi=no]
+ )
+
dnl *** Midifile
AC_ARG_ENABLE([input_midifile],
AS_HELP_STRING([--disable-input-midifile], [Disable input midifile plugin [default=enabled]]),,
@@ -502,10 +528,7 @@ AS_IF(
AS_IF(
[test "x$enable_output_alsa" = "xyes"],
[have_output_alsa=yes
- dnl ======================
- dnl Check for alsa library
- dnl ======================
- PKG_CHECK_MODULES(ALSA, alsa >= 1.0.18)],
+ need_alsa=yes],
[AC_MSG_RESULT([*** output alsa plugin disabled per user request ***])
have_output_alsa=no]
@@ -582,6 +605,7 @@ AM_CONDITIONAL([ENABLE_CLI], [test "x$enable_cli" == "xyes"])
AM_CONDITIONAL([HAVE_INPUT_DUMMY], [test "x$have_input_dummy" = "xyes"])
AM_CONDITIONAL([HAVE_INPUT_TEST], [test "x$have_input_test" = "xyes"])
AM_CONDITIONAL([HAVE_INPUT_JACKMIDI], [test "x$have_input_jackmidi" = "xyes"])
+AM_CONDITIONAL([HAVE_INPUT_ALSAMIDI], [test "x$have_input_alsamidi" = "xyes"])
AM_CONDITIONAL([HAVE_INPUT_OSSMIDI], [test "x$have_input_ossmidi" = "xyes"])
AM_CONDITIONAL([HAVE_INPUT_MIDIFILE], [test "x$have_input_midifile" = "xyes"])
AM_CONDITIONAL([HAVE_OUTPUT_DUMMY], [test "x$have_output_dummy" = "xyes"])
@@ -697,6 +721,11 @@ dnl Check for jack
dnl ======================
AS_IF([test "x$need_jack" = "xyes"], [PKG_CHECK_MODULES(JACK, jack >= 0.120.1)])
+dnl ======================
+dnl Check for alsa library
+dnl ======================
+AS_IF([test "x$need_alsa" = "xyes"], [PKG_CHECK_MODULES(ALSA, alsa >= 1.0.18)])
+
AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
AC_SUBST(CXXFLAGS)
@@ -709,6 +738,7 @@ AC_CONFIG_FILES(
src/Makefile
plugin/Makefile
plugin/vst/Makefile
+ dggui/Makefile
plugingui/Makefile
plugingui/locale/Makefile
man/Makefile