summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7e6695c..0dcf8c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,10 +142,17 @@ AC_ARG_WITH([test],
AS_HELP_STRING([--with-test], [Build unit tests]))
AS_IF([test x$with_test == xyes],
- [AC_MSG_WARN([*** Building unittests!])
- AM_PATH_CPPUNIT(1.9.6)]
+ [
+ AC_MSG_WARN([*** Building unittests!])
+ PKG_CHECK_MODULES([CPPUNIT], [ cppunit >= 1.9.6 ], [],
+ [
+ AC_MSG_ERROR([$CPPUNIT_PKG_ERRORS])
+ ])
+ ]
)
+AM_CONDITIONAL([ENABLE_TESTS], [test "x$with_test" = "xyes"])
+
dnl ======================
dnl Compile LV2 plugin
dnl ======================