summaryrefslogtreecommitdiff
path: root/drumgizmo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'drumgizmo/Makefile.am')
-rw-r--r--drumgizmo/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/drumgizmo/Makefile.am b/drumgizmo/Makefile.am
index 2cb46bf..7702b2e 100644
--- a/drumgizmo/Makefile.am
+++ b/drumgizmo/Makefile.am
@@ -77,6 +77,10 @@ drumgizmo_SOURCES += input/ossmidi.cc
drumgizmo_CXXFLAGS += -DHAVE_INPUT_OSSMIDI
endif # HAVE_INPUT_OSSMIDI
+if HAVE_INPUT_ALSAMIDI
+drumgizmo_SOURCES += input/alsamidi.cc
+drumgizmo_CXXFLAGS += -DHAVE_INPUT_ALSAMIDI
+endif # HAVE_INPUT_ALSAMIDI
# Only compile jackclient.cc if at least one of the jack modules are included.
if HAVE_OUTPUT_JACKAUDIO
@@ -93,6 +97,7 @@ EXTRA_DIST = \
input/inputdummy.h \
input/test.h \
input/jackmidi.h \
+ input/alsamidi.h \
input/midifile.h \
input/ossmidi.h \
output/alsa.h \
@@ -109,7 +114,7 @@ dgvalidator_CXXFLAGS = \
-I$(top_srcdir)/src -I$(top_srcdir)/getoptpp \
-I$(top_srcdir)/hugin -DWITH_HUG_MUTEX -DWITH_HUG_FILTER \
$(SSEFLAGS) \
- -I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/ \
-DLODEPNG_NO_COMPILE_ENCODER \
-DLODEPNG_NO_COMPILE_DISK \
-DLODEPNG_NO_COMPILE_ANCILLARY_CHUNKS \
@@ -122,9 +127,9 @@ dgvalidator_SOURCES = \
dgvalidator.cc \
$(top_srcdir)/hugin/hugin.c \
$(top_srcdir)/hugin/hugin_filter.c \
- $(top_srcdir)/plugingui/lodepng/lodepng.cpp \
- $(top_srcdir)/plugingui/image.cc \
- $(top_srcdir)/plugingui/resource.cc \
- $(top_srcdir)/plugingui/colour.cc
+ $(top_srcdir)/dggui/lodepng/lodepng.cpp \
+ $(top_srcdir)/dggui/image.cc \
+ $(top_srcdir)/dggui/resource.cc \
+ $(top_srcdir)/dggui/colour.cc
endif # ENABLE_CLI