summaryrefslogtreecommitdiff
path: root/drumgizmo/input/test/Makefile.am
diff options
context:
space:
mode:
authorJonas Suhr Christensen <jsc@umbraculum.org>2014-12-05 23:50:25 +0100
committerJonas Suhr Christensen <jsc@umbraculum.org>2014-12-05 23:50:25 +0100
commit33f888cd8ba0bbb258b0cec6568f60801364c697 (patch)
tree0ef2ee00d843492f39e65781992552b14e611ebf /drumgizmo/input/test/Makefile.am
parentd31ef86d0b51092bab5813f1cc893fdf6d688123 (diff)
parent64d4f8d1b55d7f3f4099bd185ca326b5331798cc (diff)
Merge branch 'master' of http://git.drumgizmo.org/drumgizmov0.9.7
Forced to write this message.
Diffstat (limited to 'drumgizmo/input/test/Makefile.am')
-rw-r--r--drumgizmo/input/test/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/drumgizmo/input/test/Makefile.am b/drumgizmo/input/test/Makefile.am
index 0b65a67..35466ab 100644
--- a/drumgizmo/input/test/Makefile.am
+++ b/drumgizmo/input/test/Makefile.am
@@ -4,7 +4,7 @@ testsources = \
if HAVE_INPUT_TEST
-testltlibs = libtest.la
+testltlibs = test.la
testbuildsources = $(testsources)
else
@@ -21,6 +21,9 @@ lib_LTLIBRARIES = $(testltlibs)
libdir = $(INPUT_PLUGIN_DIR)
AM_CPPFLAGS = -I$(top_srcdir)/include
-libtest_la_LDFLAGS =
-libtest_la_LIBADD =
-libtest_la_SOURCES = $(testbuildsources)
+test_la_LDFLAGS = -module -avoid-version -shared
+test_la_LIBADD =
+test_la_SOURCES = $(testbuildsources)
+
+install-exec-hook:
+ rm -f $(DESTDIR)$(libdir)/test.la